Wordup CLI

note

This documentation is only valid for wordup-cli >= 1.0.0

With the Wordup CLI you will be able to setup local WordPress installations and develop and publish your WordPress plugins or themes with just a few clicks.

Requirements

Make sure you have node >= 8.3 (npm >= 5.2) and docker-compose installed on your machine.

Installation

We recommend to install wordup-cli globally with npm:

$ npm install -g wordup-cli

or with yarn:

$ yarn global add wordup-cli

Start

After installing wordup-cli, you can create your first project with wordup init. Go to Development for detailed information.

Commands

The detailed documentation of all commands is available under: https://github.com/wordup-dev/wordup-cli